Monday, 23 October 2017

Motorola Moto G3... SD Card Issues

I have become a big fan of the Motorola Moto G series of handsets, in fact there are six in my household ranging from the original Moto G from 2013 up to the Moto G4 from 2016. They are excellent quality handsets offering fantastic value for money and brilliant performance. 

However, there has been one issue which has plagued my sons Moto G3 (XT1541) for months and it regards MicroSD cards. I know MicroSD cards aren’t the most reliable but I haven’t had issues in any other handset.

The Moto G3 seems to destroy cards. They work for a few weeks at most, then experience intermittent working before not being recognised at all after which they will not be recognised in any phone or computer.



At first I thought it was an old 8GB card I was using. Then I bought some 16GB cards from eBay, the same happened and I thought perhaps they were just cheap cards. However I bought a 16GB SanDisk cards from a reputable supermarket and the same happened again.

Officially it should take up to a 32GB microSDXC.

Not only is this annoying and a loss of data but it is also becoming an expense I wish I didn’t have.

Searching around this is a common issue, but with no obvious fix. Some say the Marshmallow update caused it, some say they have it on Lollipop. Some say it is caused by using the card as internal storage but others - like myself - have it when using it as portable storage.

There are claims that it is a problem with Class 10 cards, but I have yet to test this out.

For the past three months my son has had an unbranded 2GB card in and working fine. Is this a lower Class card? Is it because of its small size? While it is promising that a card is working, 2GB is just too small.

If it is hardware related then a resolution isn’t possible, but if it is a software issue then Motorola should have listened to the very common problem and issued a fix for it.

Have you experienced this? Have you found a solution?

Written by Simon Royal. Follow me at twitter.com/simonroyal



1 comment:

Bruce Austin said...

Since Friday 24th November 2017 I am suffering a problem with my Moto G3 it seems to be automatically removing the SD card. It has worked perfectly for the past six months.
When I switch on the phone and go to settings, it reads the 32gb card and tells me less than 2gb has been used, and after about 2 minutes, while I am watching the screen it changes to "card not inserted". Each time I remove and reinsert the card, it again recognises it and then comes up with the same not inserted message. Any suggestions please?